What are the requirements for Active Directory Sync on Workplace?

This article is only applicable to users of Workplace Essential and Workplace Advanced.
The AD Sync Component requires the following:
  • Software installation must be run by a user with AD Domain Administrator privileges.
  • AD Sync is designed to run on Windows Server 2012 R2 or Windows Server 2016. Other configurations may work (when the OS language is set to en_US), but aren't supported by Workplace.
  • AD Sync needs to run on a computer that is domain-joined to the same AD controller that your Workplace users belong to. If your Workplace users belong to multiple AD Domains, you may need to follow the installation and configuration procedure for AD Sync on a server in each domain.
  • The following Microsoft components are required and will be installed with AD Sync if they're not already on the server: .NET Framework 4.5.2, and SQL Server 2014 Express LocalDB (a light version of SQL Server Express) to store user data. All cumulative updates should be installed.
  • For each group of users that you want to sync to Workplace from Facebook, you must identify: the Distinguished Name (DN) of the root entry in Active Directory that contains the users, and either an LDAP Filter or an Active Directory Group that identifies the users you want to sync to Workplace.
  • Your Domain Controller must be able to support LDAPS (SSL) connections over port 636.
Was this information helpful?